Upgrade System Requirements

The following components must be installed to use RiskVision: 

  1. RiskVision Server: 

    • Apache Web Server

    • Tomcat Application Server

    • MySQL or Oracle database

      If the Apache Web Server, Apache Tomcat, MySQL, and/or Java services are already installed on your system, but require a version upgrade, you may be able to use the Minor Version Upgrade installer to perform these upgrades. See the Minor Version Upgrade Installer section for more information and a list of prerequisites.
      If the user installs Apache Tomcat at a version newer than 8.5.50(Both Risk vision and connector manager) the Tomcat service shown in Local Service which can cause problems in accessing folders. To ensure the smooth running of Risk Visionchange the name of the service to Local System Account.
  2. RiskVisionReport Server (JasperReports Server)

System Requirements

The following hardware requirements represent the minimum system requirements to install Resolver RiskVision™ V. 9.7. These specifications are for planning purposes only. To learn about the recommended hardware and software for your environment, contact Resolver Support.  

Hardware

Minimum

Total number of CPU cores

8

Memory

16 GB

Disk Space

At least 100 GB of free disk space 

Resolver recommends increasing the RAM of the National Vulnerability Database Connector by at least 500 MB to accomodate the CPE Match Feed from RiskVision version 9.3 and higher.

Supported Third-Party Software

Product

Version

Operating System

Microsoft Windows Server® 2019

Amazon Coretto (JDK)

1.8.302.08.1

Apache Tomcat

8.5.57

Apache Web Server

2.4.51

Apache OpenOffice

4.1.7

Jasper Reports Server

7.9

MySQL

5.7.35

Oracle

12.2.0.1.0

Web Browser 

Microsoft Internet Explorer® 11, Microsoft Edge, Mozilla Firefox®, Google Chrome®

Adobe® Flash browser plug-in

Adobe® Flash Player, version 11 (optional)

Microsoft Visual C++

2013 x64 Redistributable - 12.0.30501, 2008 x64 Redistributable - 9.0.30729.6161 (Optional- to run Apache open office), C++ 2008 x86 Redistributable - 9.0.30729.6161, 2010 x86 Redistributable - 10.0.40219, Microsoft Visual C++ 2015 Redistributable (x64)

Open SSL

1.0.2r

Users who wish to use Tomcat version 8.5.35 or above must update their RiskVision software to version 9.3 or higher.

JasperReports Server 7.9 comes with the following technologies:

Product

Version

PostgreSQL

11.8

Apache Tomcat

8.5.34

Oracle JDK 8 

1.8.0_241

TIBCO Data Virtualization

8.3.0

ElasticSearch

7.9

Vertica

10.0

JasperReports Server 7.9 cannot be installed on a Windows 2019 OS server. The user must install Microsoft Visual C++ 2015 Redistributable (x64) first.